Проблема с установкой библиотеки при помощи CocoaPods (linker command failed with exit code 1)

Мой первый опыт в установке библиотек в мой XCode-проект, но не могу разрешить проблему.

Мой podfile, как и положено, находится в папке c проектом и его вид следующий:

platform :ios, '12.1'
use_frameworks!

target "StudyHandyTest" do
pod 'RealmSwift'
end

Далее работа через терминал:

Захожу в расположение проекта: cd /projectDir/

Запускаю установку библиотеки RealmSwift: pod install

Результат процесса установки:

Analyzing dependencies
Downloading dependencies
Installing Realm (10.5.1)
[!] /bin/bash -c 
set -e
sh build.sh cocoapods-setup

Downloading dependency: 10.3.3 from https://static.realm.io/downloads/core/realm-monorepo-xcframework-v10.3.3.tar.xz
Undefined symbols for architecture x86_64:
  "___isPlatformVersionAtLeast", referenced from:
      realm::util::(anonymous namespace)::ensure_reclaimer_thread_runs() in librealm-monorepo.a(file_mapper.o)
      realm::util::terminate_internal(std::__1::basic_stringstream<char, std::__1::char_traits<char>, std::__1::allocator<char> >&) in librealm-monorepo.a(terminate.o)
      realm::util::network::SecureTransportErrorCategory::message(int) const in librealm-monorepo.a(network_ssl.o)
      realm::util::network::ssl::Stream::verify_peer() in librealm-monorepo.a(network_ssl.o)
      realm::util::Scheduler::make_dispatch(void*) in librealm-monorepo.a(scheduler.o)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Ответы (1 шт):

Автор решения: JustKamil

Нашёл на оф. сайте Realm следующее требование для последней версии RealmSwift:

Xcode 11.3 и выше, в то время как у меня версия 10.1

Решение: указал на специфичную версию RealmSwift (поддерживающую текущую версию Xcode) в cocoapods:

pod 'RealmSwift', '3.7.4'

Вывод: Проверяйте совместимость библиотек с версией IDE

→ Ссылка